Precompiled libs not compatible


#1

Hi, I’ve downloaded latest versions as per instructions on https://docs.lightstreams.network/getting-started/install/

When running leth I’m getting a version mismatch error:

radek$ leth init --nodeid=1 --network=sirius
2019-03-25T12:25:47.682+1100 INFO lethnode/node.go:75 Initializing Leth node… {“nodeID”: 1, “network”: “sirius”}
2019-03-25T12:25:47.684+1100 INFO lethnode/node_dir.go:44 Leth node config file successfully initialized at /Users/radek/.lightstreams_1/config.json
2019-03-25T12:25:47.774+1100 FATAL leth/init.go:44 lightchain version ‘0.10’ was not found in ‘lightchain version’ output: Version: 0.12.0-alpha Gas Price


#2

Hi Radek,

Which version of leth are you running at the minute? which OS are you using?

If you run leth version it should produce the following output:

$> leth version
Version: 0.9.0-alpha Sirius

if not, please download the latest version indicated in the install steps


#3

Hi, I’m on macos, yes I followed the install steps and installed the latest binaries. leth is at version 0.9.0-alpha Sirius


#4

Hey Radek,

We added tags to the repository and re-uploaded the binaries. Try again please and sorry for the inconvenience.

/usr/local/bin/lightchain version
Version: 0.12.0-alpha Gas Price

/usr/local/bin/leth version
Version: 0.9.1-alpha Sirius

#5

Hi Radek,

How are you doing? Did you get to sort out this incompatibility issue? if not, let us know and we just created a Telegram group to support developers like you https://t.me/LightstreamsDevelopers.

Also we would like to inform you that we recently got to launch our Mainnet and a long with it new versions of Leth and Lightchain.

> leth version
Version: 0.11.0-alpha Mainnet

> lightchain version
Version: 1.0.0-beta MainNet

Best,